Commodore PET restoration help

Welcome back to our Commodore Discussion forum. If you have a question, comment, problem, or just want to chat about Commodore, post it here for free.

Have some fun and talk to others interested in the Old and New Commodore world.

Moderators: wiskow, Trazan

Post Reply
User avatar
SkyCaptain
Posts: 1
Joined: Tue May 19, 2020 11:18 pm
Are you a real person?: No... I am a spambot, delete my account!

Commodore PET restoration help

Post by SkyCaptain »

Hey Guys Very first post here so please point me in the right direction if i posted this in the wrong Forum, i just picked up a nice commodore PET. It has some scuff marks and some paint chipped off on some corners but that doesnt worry me. The screen is also very nice with the contrast setting working really good.

It also has a bunch of custom modification i see when i open it. A reset button, i presume is among the more prominent features.

About half of the Chips inside have a sticker on them with a weird Logo, a logo i later identified as the local computer store that obviously doesnt exist anymore.

Buuut: When i turn it on, the only thing I see is a "#" sign floating somewhere in the upper left corner.
When i google the issue, google interestingly shows me the "Commodore PET hash" as a suggested search, so i assume its a more common issue, but when i actually do the search, nothing of value has come up (so far). Does anyone know where to start the trouble shooting? This really is my first experience with these things other than owning a fully functioning and original one that never needed any work done.

But yeah, thanks for any insight on that "#" issue!
User avatar
LoneWolf33
Posts: 67
Joined: Tue May 14, 2013 9:42 am
Are you a real person?: No... I am a spambot, delete my account!
Location: Budapest, Hungary

Re: Commodore PET restoration help

Post by LoneWolf33 »

Hi, and welcome to the forum !

I think the # sign may indicates ROM failure: the machine stuck in the boot process due to an illegal instruction.
Post Reply